using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:24|[a-zA-Z ]*)+([a-zA-Z0-9\s]*)";
string input = @"asdfafj as sadf6";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}