$re = '/^(?:24|[a-zA-Z ]*)+([a-zA-Z0-9\s]*)/';
$str = 'asdfafj as sadf6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);