package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(?:24|[a-zA-Z ]*)+([a-zA-Z0-9\s]*)`)
var str = `asdfafj as sadf6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}