import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\+\\d-)?\\(?(\\d{1,3})\\)?[\\s-\\.]?(\\d{1,3})[\\s-\\.]?(\\d{1,4})[\\s-\\.]?";
final String string = "555.123.4565\n"
+ "+1-(800)-545-2468\n"
+ "555-123-3456\n"
+ "555 222 3342\n"
+ "(234) 234 2442\n"
+ "(243)-234-2342\n"
+ "1234567890\n"
+ "(123)2567890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}