import Foundation
let pattern = #"^(\+\d-)?\(?(\d{1,3})\)?[\s-\.]?(\d{1,3})[\s-\.]?(\d{1,4})[\s-\.]?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
555.123.4565
+1-(800)-545-2468
555-123-3456
555 222 3342
(234) 234 2442
(243)-234-2342
1234567890
(123)2567890
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)