using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([0-9A-Fa-f]{0,4}:){2,7}([0-9A-Fa-f]{1,4}$|((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.|$)){4})$";
string input = @"Valid:
1:2:3:4:5:6:7:8
1::
::1
2001:db8:3:4::192.0.2.33
64:ff9b::192.0.2.33
FEDC:BA98:7654:3210:FEDC:BA98:7654:3210
1080:0:0:0:8:800:200C:417A
0:0:0:0:0:0:0:1
::0:0:0:FFFF:129.144.52.38
FEDC:BA98::3210:FEDC:BA98:7654:3210
::13.1.68.3
Invalid:
128.0.0.1
FEDC:BA98:7654:3210:FEDC:BA98:7654:3210:AA31
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}