import re
regex = re.compile(r"^([0-9A-Fa-f]{0,4}:){2,7}([0-9A-Fa-f]{1,4}$|((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.|$)){4})$", flags=re.MULTILINE)
test_str = ("Valid:\n"
"1:2:3:4:5:6:7:8\n"
"1::\n"
"::1\n"
"2001:db8:3:4::192.0.2.33\n"
"64:ff9b::192.0.2.33\n"
"FEDC:BA98:7654:3210:FEDC:BA98:7654:3210\n"
"1080:0:0:0:8:800:200C:417A\n"
"0:0:0:0:0:0:0:1\n"
"::0:0:0:FFFF:129.144.52.38\n"
"FEDC:BA98::3210:FEDC:BA98:7654:3210\n"
"::13.1.68.3\n\n"
"Invalid:\n"
"128.0.0.1\n"
"FEDC:BA98:7654:3210:FEDC:BA98:7654:3210:AA31\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")