use strict;
my $str = 'Valid:
1:2:3:4:5:6:7:8
1::
::1
2001:db8:3:4::192.0.2.33
64:ff9b::192.0.2.33
FEDC:BA98:7654:3210:FEDC:BA98:7654:3210
1080:0:0:0:8:800:200C:417A
0:0:0:0:0:0:0:1
::0:0:0:FFFF:129.144.52.38
FEDC:BA98::3210:FEDC:BA98:7654:3210
::13.1.68.3
Invalid:
128.0.0.1
FEDC:BA98:7654:3210:FEDC:BA98:7654:3210:AA31
';
my $regex = qr/^([0-9A-Fa-f]{0,4}:){2,7}([0-9A-Fa-f]{1,4}$|((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)(\.|$)){4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}