import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?P<id_1>a|b|c)\\b(?:(?!\\b(?:q|w)\\b).)*(?P<id_2>q|w)?\\b";
final String string = "a something* q b c w\n"
+ "a something* w\n"
+ "a\n"
+ "a w";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}