re = /\b(?P<id_1>a|b|c)\b(?:(?!\b(?:q|w)\b).)*(?P<id_2>q|w)?\b/i
str = 'a something* q b c w
a something* w
a
a w'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end