$re = '/DELIM1(.*?)DELIM2([^D]*(?:D(?!ELIM1)[^D]*)*)/';
$str = 'DELIM1test1DELIM2test2DELIM1test3DELIM2test4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);