re = /DELIM1(.*?)DELIM2([^D]*(?:D(?!ELIM1)[^D]*)*)/
str = 'DELIM1test1DELIM2test2DELIM1test3DELIM2test4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end