import Foundation
let pattern = #"DELIM1(.*?)DELIM2([^D]*(?:D(?!ELIM1)[^D]*)*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"DELIM1test1DELIM2test2DELIM1test3DELIM2test4"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)