$re = '~(#[0-9a-f]{6})(.+?)(?=#[0-9a-f]{6}|$)~im';
$str = '#ff00fffirstword#445533secondword##008877thi#rdword#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);