re = /(#[0-9a-f]{6})(.+?)(?=#[0-9a-f]{6}|$)/im
str = '#ff00fffirstword#445533secondword##008877thi#rdword#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end