# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^.*?)-"
test_str = ("[program:hlds] : Название программы. Служит для управления.\n"
"user - Пользователь от которого запускать сервер\n"
"environment - /steam путь к home директории пользователя от которого запускаем процесс. Все остальное оставляем как есть\n"
"process_name - имя процесса\n"
"directory - путь к директории сервера\n"
"command - команда запуска. Обратите внимания на hlds_linux вместо hlds_run\n"
"numprocs - количество процессов. В нашем случае 1\n"
"startretries - количество попыток автоподнятия при падении. При превышении сервер больше не поднимется\n"
"autostart - автозапуск при запуске ОС\n"
"autorestart - автоперезапуск при падении\n"
"stdout_logfile - путь к логфайлу\n"
"stdout_logfile_maxbytes - максимальный размер лог файла\n"
"stdout_logfile_backups - максимальное количество лог файлов\n"
"redirect_stderr - переадресация потока ошибок\n"
"stderr_logfile - путь к логу ошибок\n"
"stderr_logfile_maxbytes - максимальный размер файла ошибок\n"
"stderr_logfile_backups - максимальное количество файлов - ошибок\n\n"
"## найти первое тире")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.