# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?P<artist>.+?(?=\s-\s)) # artist with pos. lookahead
\s-\s # space - space
(?P<title>.+?(?=(?:\(?Feat\.)|$)) # title with pos. lookahead
\(? # optional open parenthesis
(?P<artist2>Feat\.[^()\n]+)? # artist2 with Feat. before
\)? # optional closing parenthesis
(?P<subtitle>.+)?$ # optional subtitle/$1 $3 - $2$4/gmx;t' <<< "Black Coast - Trndsttr
Black Coast - Trndsttr (Feather)
Black Coast - Trndsttr (Lucian Remix)
Black Coast - Trndsttr (Feather) (Lucian Remix)
Black Coast - Trndsttr Feat. M. Maggie
Black Coast - Trndsttr (Feat. M. Maggie)
Black Coast - Trndsttr Feat. M. Maggie (Lucian Remix)
Black Coast - Trndsttr (Feat. M. Maggie) (Lucian Remix)
Black Coast - Trndsttr (Lucian Remix) Feat. M. Maggie
Black Coast - Trndsttr (Lucian Remix) (Feat. M. Maggie)
Black Coast - Trndsttr (Feather) (Lucian Remix) Feat. M. Maggie
Black Coast - Trndsttr (Feather) (Lucian Remix) (Feat. M. Maggie)
Black Coast - Trndsttr (Feather) Feat. M. Maggie (Lucian Remix)
Black Coast - Trndsttr (Feather) (Feat. M. Maggie) (Lucian Remix)
Black Coast - Trndsttr (Feather) (Feat. M. Maggie) Lucian Remix
Black Coast - Trndsttr (Feather) Feat. M. Maggie Lucian Remix
"