import Foundation
let pattern = ##"""
^(?P<artist>.+?(?=\s-\s)) # artist with pos. lookahead
\s-\s # space - space
(?P<title>.+?(?=(?:\(?Feat\.)|$)) # title with pos. lookahead
\(? # optional open parenthesis
(?P<artist2>Feat\.[^()\n]+)? # artist2 with Feat. before
\)? # optional closing parenthesis
(?P<subtitle>.+)?$ # optional subtitle
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
Black Coast - Trndsttr
Black Coast - Trndsttr (Feather)
Black Coast - Trndsttr (Lucian Remix)
Black Coast - Trndsttr (Feather) (Lucian Remix)
Black Coast - Trndsttr Feat. M. Maggie
Black Coast - Trndsttr (Feat. M. Maggie)
Black Coast - Trndsttr Feat. M. Maggie (Lucian Remix)
Black Coast - Trndsttr (Feat. M. Maggie) (Lucian Remix)
Black Coast - Trndsttr (Lucian Remix) Feat. M. Maggie
Black Coast - Trndsttr (Lucian Remix) (Feat. M. Maggie)
Black Coast - Trndsttr (Feather) (Lucian Remix) Feat. M. Maggie
Black Coast - Trndsttr (Feather) (Lucian Remix) (Feat. M. Maggie)
Black Coast - Trndsttr (Feather) Feat. M. Maggie (Lucian Remix)
Black Coast - Trndsttr (Feather) (Feat. M. Maggie) (Lucian Remix)
Black Coast - Trndsttr (Feather) (Feat. M. Maggie) Lucian Remix
Black Coast - Trndsttr (Feather) Feat. M. Maggie Lucian Remix
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $3 - $2$4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)