# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
^(?P<artist>.+?(?=\s-\s)) # artist with pos. lookahead
\s-\s # space - space
(?P<title>.+?(?=(?:\(?Feat\.)|$)) # title with pos. lookahead
\(? # optional open parenthesis
(?P<artist2>Feat\.[^()\n]+)? # artist2 with Feat. before
\)? # optional closing parenthesis
(?P<subtitle>.+)?$ # optional subtitle
"""
test_str = ("Black Coast - Trndsttr\n"
"Black Coast - Trndsttr (Feather)\n"
"Black Coast - Trndsttr (Lucian Remix)\n"
"Black Coast - Trndsttr (Feather) (Lucian Remix)\n"
"Black Coast - Trndsttr Feat. M. Maggie\n"
"Black Coast - Trndsttr (Feat. M. Maggie)\n"
"Black Coast - Trndsttr Feat. M. Maggie (Lucian Remix)\n"
"Black Coast - Trndsttr (Feat. M. Maggie) (Lucian Remix)\n"
"Black Coast - Trndsttr (Lucian Remix) Feat. M. Maggie\n"
"Black Coast - Trndsttr (Lucian Remix) (Feat. M. Maggie)\n"
"Black Coast - Trndsttr (Feather) (Lucian Remix) Feat. M. Maggie\n"
"Black Coast - Trndsttr (Feather) (Lucian Remix) (Feat. M. Maggie)\n"
"Black Coast - Trndsttr (Feather) Feat. M. Maggie (Lucian Remix)\n"
"Black Coast - Trndsttr (Feather) (Feat. M. Maggie) (Lucian Remix)\n"
"Black Coast - Trndsttr (Feather) (Feat. M. Maggie) Lucian Remix\n"
"Black Coast - Trndsttr (Feather) Feat. M. Maggie Lucian Remix\n")
subst = "$1 $3 - $2$4"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.