const regex = /^(?=.{0,20}$).*(?:Bus: red|Car: blue)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{0,20}$).*(?:Bus: red|Car: blue)', 'gm')
const str = `Bus: red, Car: blue
Bus: red, Car: blue - too long to match`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}