re = /^(?=.{0,20}$).*(?:Bus: red|Car: blue)/m
str = 'Bus: red, Car: blue
Bus: red, Car: blue - too long to match'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end