$re = '/^(?=.{0,20}$).*(?:Bus: red|Car: blue)/m';
$str = 'Bus: red, Car: blue
Bus: red, Car: blue - too long to match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);