using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\pL+";
string input = @"ключевое слово
или такое ключевое слово
а может быть и такое ключевое слово";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}