$re = '/\pL+/m';
$str = 'ключевое слово
или такое ключевое слово
а может быть и такое ключевое слово';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);