re = /\pL+/m
str = 'ключевое слово
или такое ключевое слово
а может быть и такое ключевое слово'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end