# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\+|-)?(\d+x|\d+)(\^\d+)?//g;t' <<< "5x^10-3x^2+4"