import re
regex = re.compile(r"(\+|-)?(\d+x|\d+)(\^\d+)?")
test_str = "5x^10-3x^2+4"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)