use strict;
my $str = '5x^10-3x^2+4';
my $regex = qr/(\+|-)?(\d+x|\d+)(\^\d+)?/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";