#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(.{10}hars/t.{10})"
Local $sString = "+!This is a text% with some % special chars/text and ( for a string query to matc%h. Then !! mor&&&e and so on...chars/text."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")