import Foundation
let pattern = #"(.{10}hars/t.{10})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"+!This is a text% with some % special chars/text and ( for a string query to matc%h. Then !! mor&&&e and so on...chars/text."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}