// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(.{10}hars/t.{10})").unwrap();
let string = "+!This is a text% with some % special chars/text and ( for a string query to matc%h. Then !! mor&&&e and so on...chars/text.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}