const regex = /(\.\d{4})\d+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\.\\d{4})\\d+', 'gm')
const str = `20.1234567890123,20.1234567890123`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);