$re = '/(\.\d{4})\d+/m';
$str = '20.1234567890123,20.1234567890123';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;