re = /(\.\d{4})\d+/m
str = '20.1234567890123,20.1234567890123'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result