#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\bAmountAfterTax="\K(\d+)\.(\d+)"
Local $sString = "AmountAfterTax="48.85" CurrencyCode="USD" Percentage="50.00""
Local $sSubst = "$1$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)