import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bAmountAfterTax=\"\\K(\\d+)\\.(\\d+)";
final String string = "AmountAfterTax=\"48.85\" CurrencyCode=\"USD\" Percentage=\"50.00\"";
final String subst = "$1$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}