import re
regex = re.compile(r"\bAmountAfterTax=\"\K(\d+)\.(\d+)", flags=re.MULTILINE)
test_str = "AmountAfterTax=\"48.85\" CurrencyCode=\"USD\" Percentage=\"50.00\""
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)