package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`test[^\(]*\(self,`)
var str = `Test_order_of_suggestions_obtained_by_yes_indicator(self, param)`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}