const regex = /test[^\(]*\(self,/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('test[^\\(]*\\(self,', '')
const str = `Test_order_of_suggestions_obtained_by_yes_indicator(self, param)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}