$re = '/test[^\(]*\(self,/';
$str = 'Test_order_of_suggestions_obtained_by_yes_indicator(self, param)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);