import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\()(?:'[^']*'|[,\\s]+|\\d+)+(?=\\))";
final String string = "('Android KitKat(4.4) Devices', ':)', '&:*(' , 'Slendrina:The Cellar (Free)') \n"
+ "(11,'-1','Service A (nested parentheses)','en') (22,'-2','Service B (nested parentheses)','en')";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}