const regex = /(?<=\()(?:'[^']*'|[,\s]+|\d+)+(?=\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\()(?:\'[^\']*\'|[,\\s]+|\\d+)+(?=\\))', 'g')
const str = `('Android KitKat(4.4) Devices', ':)', '&:*(' , 'Slendrina:The Cellar (Free)')
(11,'-1','Service A (nested parentheses)','en') (22,'-2','Service B (nested parentheses)','en')`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}