$re = '/(?<=\()(?:\'[^\']*\'|[,\s]+|\d+)+(?=\))/';
$str = '(\'Android KitKat(4.4) Devices\', \':)\', \'&:*(\' , \'Slendrina:The Cellar (Free)\')
(11,\'-1\',\'Service A (nested parentheses)\',\'en\') (22,\'-2\',\'Service B (nested parentheses)\',\'en\')';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);