# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[^0-9A-Za-zぁ-んァ-ン一-龥ovっつ゜ニノ三二]*[\(∩ (][^0-9A-Za-zぁ-んァ-ン一-龥ヲ-゚\)∩ )]{3,}[\)∩ )][^0-9A-Za-zぁ-んァ-ン一-龥ovっつ゜ニノ三二]*"
test_str = ("ふう。お腹いっぱい( ´•౪•`), 試験頑張るぞ\\\\\\ ٩( ‘ω’ )و ////\n"
"心の相談は メール tiknathan@mail.goo.ne.jp までご連絡ください\n"
"ドーピング系浪人生(n=1)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.