#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)type\s([_A-Za-z]+)\s*=\s*(function|procedure)(.*?cdecl;)\s*var(\s[_A-Za-z]+):\s*([_A-Za-z]+)\s(external.*?;)"
Local $sString = "" & @CRLF & _
"// It's better to create the object with the right prototype from the start." & @CRLF & _
"type TJS_SetPrototype = function (cx: PJSContext; var obj: PJSObject;" & @CRLF & _
" var proto: PJSObject):Boolean; cdecl;" & @CRLF & _
"var JS_SetPrototype: TJS_SetPrototype external SpiderMonkeyLib name 'SM_SetPrototype';" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"/// Write access an object's reserved slots" & @CRLF & _
"type TJS_SetReservedSlot = procedure (obj: PJSObject; index: uint32;" & @CRLF & _
" var v: jsval); cdecl;" & @CRLF & _
"var JS_SetReservedSlot: TJS_SetReservedSlot external SpiderMonkeyLib name 'SM_SetReservedSlot';" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")