import re
regex = re.compile(r"type\s([_A-Za-z]+)\s*=\s*(function|procedure)(.*?cdecl;)\s*var(\s[_A-Za-z]+):\s*([_A-Za-z]+)\s(external.*?;)", flags=re.DOTALL)
test_str = ("\n"
"// It's better to create the object with the right prototype from the start.\n"
"type TJS_SetPrototype = function (cx: PJSContext; var obj: PJSObject;\n"
" var proto: PJSObject):Boolean; cdecl;\n"
"var JS_SetPrototype: TJS_SetPrototype external SpiderMonkeyLib name 'SM_SetPrototype';\n\n\n"
"/// Write access an object's reserved slots\n"
"type TJS_SetReservedSlot = procedure (obj: PJSObject; index: uint32;\n"
" var v: jsval); cdecl;\n"
"var JS_SetReservedSlot: TJS_SetReservedSlot external SpiderMonkeyLib name 'SM_SetReservedSlot';\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")