import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "type\\s([_A-Za-z]+)\\s*=\\s*(function|procedure)(.*?cdecl;)\\s*var(\\s[_A-Za-z]+):\\s*([_A-Za-z]+)\\s(external.*?;)";
final String string = "\n"
+ "// It's better to create the object with the right prototype from the start.\n"
+ "type TJS_SetPrototype = function (cx: PJSContext; var obj: PJSObject;\n"
+ " var proto: PJSObject):Boolean; cdecl;\n"
+ "var JS_SetPrototype: TJS_SetPrototype external SpiderMonkeyLib name 'SM_SetPrototype';\n\n\n"
+ "/// Write access an object's reserved slots\n"
+ "type TJS_SetReservedSlot = procedure (obj: PJSObject; index: uint32;\n"
+ " var v: jsval); cdecl;\n"
+ "var JS_SetReservedSlot: TJS_SetReservedSlot external SpiderMonkeyLib name 'SM_SetReservedSlot';\n";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}