#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^.*?345.*$|^(?!(?:.*\d){3,}).*$"
Local $sString = "abc 123 cdf" & @CRLF & _
"aze ert" & @CRLF & _
"vfg 12 gj" & @CRLF & _
"zrr 345 rty" & @CRLF & _
"top flg 567" & @CRLF & _
"aze 345 odi"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")