$re = '/^.*?345.*$|^(?!(?:.*\d){3,}).*$/im';
$str = 'abc 123 cdf
aze ert
vfg 12 gj
zrr 345 rty
top flg 567
aze 345 odi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);