import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?345.*$|^(?!(?:.*\\d){3,}).*$";
final String string = "abc 123 cdf\n"
+ "aze ert\n"
+ "vfg 12 gj\n"
+ "zrr 345 rty\n"
+ "top flg 567\n"
+ "aze 345 odi";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}